Subclipse in Aptana immer mit der neuesten Version von Subversion zu arbeiten

stimmen
34

Die Version von Subclipse (1.2.4) derzeit über automatischen die Aptana Plugins - Manager nicht mit der neuesten Version von Subversion arbeiten.

Ich sehe auf der Subclipse Website jedoch , dass sie 1.4.2 out für Eclipse haben. So habe ich eine neue Remote - Update - Site zu meinem Update - Manager. Wenn ich es zu installieren versucht, gesagt , dass es mir brauche ich Mylyn 3.0.0 . Also nach langem Suchen ich Mylyn 3.0.0 gefunden und hinzugefügt eine weitere neue Remote - Update - Site zu meinem Update - Manager. Dann , als ich versuchte , das zu installieren, es hat mir gesagt , ich brauche org.eclipse.ui 3.3.0 oder gleichwertig.

Mit Blick auf die Konfigurationsdetails für Aptana, es sieht aus wie es gegen Eclipse 3.2.2 gebaut wird.

Weiß jemand, ob es eine Möglichkeit ist, die Version von Eclipse Aptana zu aktualisieren, die gegen zu 3.3.0 gebaut wird? Oder wenn es eine andere Möglichkeit ist Subclipse zu bekommen mit der sehr neuesten Version von Subversion zu arbeiten?

Ich weiß, dass dies nicht unbedingt eine „Programmierung“ Frage ist, aber ich hoffe, es ist in Ordnung, da es auf die Programmier-Erfahrung sehr relevant ist.

Veröffentlicht am 01/08/2008 um 14:56
quelle vom benutzer
In anderen Sprachen...                            


4 antworten

stimmen
16

Subclipse nicht Mylyn benötigen, aber die Update-Site enthält ein Plugin, das Mylyn und Subclipse integriert. Dies ist für Menschen gedacht, die Mylyn verwenden. In Ihrem Fall würden Sie wollen nur Abwahl Mylyn im Update-Dialog.

Subclipse erfordert auch Subversion 1.5 und die entsprechende Version der JavaHL nativen Bibliotheken. Ich habe den Start einer FAQ geschrieben Menschen zu helfen , zu verstehen JavaHL und wie es zu bekommen. Siehe: http://desktop-eclipse.open.collab.net/wiki/JavaHL

Beantwortet am 15/09/2008 um 14:26
quelle vom benutzer

stimmen
6

Ich habe Probleme mit JavaHL in Eclipse Ganymede hat, wenn es in Eclipse Europa gut funktioniert. Ich bin mir nicht sicher, wie Aptana anders, aber versuchen, entweder JavaHL Upgrade oder die Umstellung auf die reinen Java-Implementierung SVNKit innerhalb der Subclipse Config.

Beantwortet am 01/08/2008 um 15:41
quelle vom benutzer

stimmen
4

wenn Sie nicht nur zu verwenden mylyn gehen diese Abhängigkeit deaktivieren. Ich bin nicht wirklich vertraut mit Aptana, aber in Eclipse können Sie erweitern, was ist und alles, was Sie nicht brauchen, deaktivieren Sie installiert.

Beantwortet am 29/08/2008 um 00:47
quelle vom benutzer

stimmen
3

Früher habe ich die Update - URL und ich installiert , um den JavaHL Adapter, das Subclipse Projekt selbst und die SVNKit Adapter BETA.

Danach es gut für mich gearbeitet, dann ist dies für Linux-Plattform hoffen, dass es für Sie arbeitet.

Beantwortet am 26/08/2008 um 14:41
quelle vom benutzer

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more